Error XAMPP di Ubuntu 8.10

gambar diambil dari : simkesugm07.wordpress.comMinggu kemarin saya mencoba menggunakan XAMPP 1.6.4 untuk membuat sebuah web di Ubuntu saya. Proses instalasi sudah selesai dengan baik dengan meletakkan berkas XAMPP di direktori /opt. Setelah selesai instal, Saya coba jalankan di console:

 
astonix@Astonix-Systems:/opt$ sudo /opt/lampp/lampp start
/opt/lampp/lampp: line 74: arch: command not found
Starting XAMPP for Linux 1.6.4…
/opt/lampp/lampp: line 74: arch: command not found
/opt/lampp/lampp: line 74: arch: command not found
XAMPP: Starting Apache with SSL (and PHP5)..
/opt/lampp/lampp: line 74: arch: command not found
XAMPP: Starting MySQL…
/opt/lampp/lampp: line 74: arch: command not found
XAMPP: Starting ProFTPD…
XAMPP for Linux started.

lalu Saya coba cek proses statusnya:

astonix@Astonix-Systems:/opt$ ps aux | grep lampp
root 5880 0.0 1.4 27212 15440 ? Ss 21:51 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
root 5905 0.0 0.0 1844 540 pts/0 S 21:51 0:00 /bin/sh/opt/lampp/bin/mysqld_safe –datadir=/opt/lampp/var/mysql –pid-file=/opt/lampp/var/mysql/Astonix-Systems.pid
nobody 5941 0.0 0.5 27668 5308 pts/0 Sl 21:51 0:00 /opt/lampp/sbin/mysqld –basedir=/opt/lampp –datadir=/opt/lampp/var/mysql –user=nobody –pid-file=/opt/lampp/var/mysql/Astonix-Systems.pid –skip-external-locking –port=3306 –socket=/opt/lampp/var/mysql/mysql.sock
nobody 5951 0.0 1.0 24440 10972 ? S 21:51 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
nobody 5954 0.0 1.2 27212 12580 ? S 21:51 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
nobody 5955 0.0 1.2 27212 12556 ? S 21:51 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
nobody 5956 0.0 1.2 27212 12556 ? S 21:51 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
nobody 5957 0.0 1.2 27212 12556 ? S 21:51 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
nobody 5958 0.0 1.2 27212 12556 ? S 21:51 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
astonix 6500 0.0 0.0 3240 804 pts/0 S+ 22:33 0:00 grep lampp

Saya coba akses lewat Browser dengan mengetikkan “localhost”, tiba-tiba timbul pesan kesalahan berikut:

Warning: file_get_contents(lang.tmp) [function.file-get-contents]: failed to open stream: Permission denied in /opt/lampp/htdocs/xampp/index.php on line 2


Warning: Cannot modify header information – headers already sent by (output started at /opt/lampp/htdocs/xampp/index.php:2) in /opt/lampp/htdocs/xampp/index.php on line 4

Yang saya herankan, sebelumnya bisa diakses dan tidak ada masalah sama sekali, dan saya juga tidak mengutak-atik source code-nya. Setelah saya analisa dan tanya ke temen-temen akhirnya ketemu juga kesalahan saya 😀 .

Saat Saya menginstal XAMPP harusnya seperti ini perintahnya :

$sudo tar xzvf xampp-linux_1_6_4. tar.gz -C /opt

Terima kasih ya Mas Manda & Yuda atas bantuannya :).

Advertisements
About

I'm not a geek, nor a techie

Posted in FOSS, GNU/Linux
4 comments on “Error XAMPP di Ubuntu 8.10
  1. Mas Astonix… gmn proyek SPBU nya dah selesaikah? Oya aku mau juga belajar Linux Ubuntu. sebaiknya aku mulai yang versi berapa yah..?

    • Astonix says:

      Wah, proyek SPBU yg mana yah? hehe… 😀

      Klo boleh tau, untuk kebutuhan apa mas Dian? pemakaian Distro Linux itu tergantung kebutuhan, versi berapapun ga masalah, yang penting sudah mencakup kebutuhan sistem yang Mas gunakan.

      OK, Met Belajar yah.. 🙂

  2. Den Mas says:

    Wah, XAMP ternyata ada yang versi linux yah? baru tahu saia :D. biasa pake yang native bawaan Ubuntu Server

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: